>How To Fix Internet Explorer Did Not Finish Installing Error

>Microsoft has released the final version of Internet Explorer 9 yesterday, and most interested users won’t have any problems installing the web browser, or updating their previous Internet Explorer version. Some users on the other hand may receive error messages such as Internet Explorer did not finish installing when they run the Internet Explorer 9 setup file.

The core reason for this error message is that a beta, preview build or release candidate build of Internet Explorer 9 is installed on the system, which prevents the installation of the final version.

Internet Explorer Did Not Finish Installing
Setup can’ continue because a more recent version of Internet Explorer is installed on your computer.

The error message does not appear if Internet Explorer 8 or IE7 are installed on the system. In this case, an upgrade is possible without problems. Users who receive the error message should look under Uninstall a Program in the control Panel to see if an earlier build of Internet Explorer is listed there. You need to make sure to look both in the third party software listing and in Installed Updates. On my test system, Internet Explorer preview builds were installed under the third party listing while the release candidate was installed under Installed Updates.

A restart of Windows is required before the uninstallation of Internet Explorer completes. Check out How to uninstall internet explorer 9 for additional uninstallation information and troubleshooting.

Some users may still run into troubles, especially if the uninstallation could not complete successfully. This was the case on a Windows 7 Professional 64-bit test system which displayed error messages when the uninstallation continued after a system restart.

The very same error message (did not finish installing) appeared again when I tried to run the Internet Explorer 9 setup, regardless whether I tried to install the 32-bit or 64-bit edition of Microsoft’s web browser, or the offline setup files.

I found a Microsoft Knowledge Base entry that suggestedto run the setup with administrative privileges. A right-click on IE9-Windows7-x64-enu.exe and the selection of Run as Administrator was all that was needed to resolve the error. The Internet Explorer 9 setup showed no further error messages and I was able to install the browser after all.

The Knowledge Base troubleshooting guide has additional tips if this one does not resolve the issue on your computer.

Advertisements

About nonerox

Btech Student
This entry was posted in Internet Explorer. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s